Welcome!

Thank you for installing Aksharamala 2004.

The purpose of this page is to give you a quick overview of Aksharamala functionality.

Test 1: Aksharamala requires that you have proper system components to display Indian Language text. Microsoft ships these display components with their Internet Explorer product. In the following sentences the one corresponding to the language you installed should be a readable sentence once Aksharamala product is successfully installed on your system.

Hindi: क्या आप इस वाक्य को पढ सकते है?

Telugu: మీరు ఈ వాక్యం చదవగలుగుతున్నారా?

Gujarati: ગુજરાતી

Tamil: தமிழ
Test 2: Now enable Aksharamala. You can do this by right-clicking on the Aksharamala icon and selecting the "Enable" menu item. Alternately, you can use the hotkey Ctrl+Shift+T to achieve the same.

You would notice that the Aksharamala icon in the tray changes to Enabled state as shown in the following picture.

Now, enter the following text exactly as it appears to understand how Aksharamala works: (As you type the text it gets transliterated to selected language)

Hindi: hindii me likhanaa ab aasaan ho gayaa!

Telugu: telugu lO vrAyaTaM ippuDu chAlA sulabhaM ayyiMdi!
Gujarati: gujaraatii
Tamil: tamiz
Test 3: Now go ahead and disable Aksharamala. You can do this either by pressing the Hotkey or right-clicking on the Aksharamala Icon in the tray, followed by selection of "Disable" menu item. Now, enter some text to ensure that Aksharamala is now disabled.

| Home | Download | Forums | Support | Feedback |
© 2000-2004 Deshweb.com Pvt. Ltd. All Rights Reserved. Terms of use.


Contacting Us

Deshweb.com Private Limited
62, Sunder Nagar
Hyderabad, AP 500038 India
Email: marketing@deshweb.com

Contact Us

For the very latest in product versions, updates and news please visit us at Aksharamala website.

Technical and product support

Product support or other related questions can be addressed to Aksharamala Forums. We will make every effort to address your issue as soon as we can. In case of delay please understand issues will be addressed in the order they are received. Please be assured that your satisfaction with our product is of prime importance to us and that we will address your issue.

Ideas, Suggestions

You could also post your ideas, suggestions and issues or find more information in the discussion forums on the site at www.aksharamala.com/forums

Business Inquiries

We also provide technical consulting services in integrating Aksharamala with other software products and in the domain of using Indian languages with software applications. For business needs please contact us at marketing@deshweb.com

Distributors in India:

Kshemankar Bhore
AJS Industries / Kshem Software
6, Yaksha Society,
New Pandit Colony
Sharanpur Road,
Nashik - 422003 MS
Email: kshemankar@flashmail.com
Phone: +91 (253) 570743 		Products Available:
  • Aksharamala 2003 Pro
    (CD & Download versions)
  • Aksharamala Developer Edition
  • Saathi - Aksharamala IE Toolbar
    (For Corporate Customers)

Kshemankar has expert level knowledge in Marathi and other Indian languages.

Mr. Mahendra
Sri Nahusha Electronics Pvt Ltd.
1-1-150, Lane Opp to YMCA
S P Road
Secunderabad, 500003 AP
Email: srinahusha@sify.com
Phone: +91 (40) 27706888 		Products Available:
  • Aksharamala Pro
    (CD & Download versions)
  • Aksharamala Developer Edition
  • Saathi - Aksharamala IE Toolbar
    (For Corporate Customers)

Contact Sri Nahusha with expert level knowledge in Telugu and other Indian languages.

Check web version of this page for up-to-date Contact & Distributor information.
Dealership enquiries: marketing@deshweb.com


What is Aksharamala?

Aksharamala is a slick, standards-based input mechanism that allows you to use an English keyboard to input text in Indian Languages. The characters you type in English are automatically transliterated to the language of your choice. It facilitates this transliteration in most Unicode-compliant software applications such as IE, MS Outlook etc., and some Unicode non-compliant applications such as Yahoo messenger.

Aksharamala does not have a separate GUI, but it rather works as a conduit for transliteration between the keyboard and the target application.


System requirements

Your system must meet these minimum requirements to run Aksharamala:

  • Windows 98, 2000, XP
  • IE 6.0 as your browser
  • Outlook Express 6.0 for sending/receiving Email
  • Windows Installer (MSI) runtime

Please Note:

Aksharamala depends on some language components (Uniscribe et al.) to be present and current on your system. Besides this, the target application should be able to receive and display Indic text properly in order for you to be able to use Aksharamala.


The License Agreement

End-user license agreement for Deshweb.com's Aksharamala software

IMPORTANT-READ CAREFULLY: This End-User License Agreement ("EULA") is a legal agreement between you (either an individual or a single entity) and Deshweb.com Pvt. Ltd. ("Deshweb") for the Deshweb software product identified above, which includes computer software and may include associated media, printed materials, and "online" or electronic documentation (collectively, "SOFTWARE PRODUCT"). By installing, copying, or otherwise using the SOFTWARE PRODUCT, you agree to be bound by the terms of this EULA. If you do not agree to the terms of this EULA, you may not use the SOFTWARE PRODUCT.

SOFTWARE PRODUCT LICENSE

The SOFTWARE PRODUCT is protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties. The SOFTWARE PRODUCT is licensed, not sold.

INTRODUCTION. The SOFTWARE PRODUCT is comprised of the following components: (i) the core Aksharamala executable and supporting DLLs; (ii) HTML files containing the documentation with English, Devanagari and other Indic languages text, which EULA will only be provided in English. English shall be deemed the language that controls the terms of this EULA.

This EULA describes your rights with respect to the SOFTWARE PRODUCT and its components.

1. GRANT OF LICENSE. This EULA grants you the following rights:

* Standard Use. You may install and use one (1) copy of the SOFTWARE PRODUCT on a single computer.

2. DESCRIPTION OF OTHER RIGHTS AND LIMITATIONS.

* Support Services. Deshweb may provide you with support services related to the SOFTWARE PRODUCT ("Support Services"). Use of Support Services is governed by the Deshweb policies and programs described in the user manual, in "on line" documentation and/or other Deshweb-provided materials. Any supplemental software code provided to you as part of the Support Services shall be considered part of the SOFTWARE PRODUCT and subject to the terms and conditions of this EULA. With respect to technical information you provide to Deshweb as part of the Support Services, Deshweb may use such information for its business purposes, including for product support and development.

* Limitations on Reverse Engineering, Decompilation, and Disassembly. You may not reverse engineer, decompile, or disassemble the SOFTWARE PRODUCT, except and only to the extent that such activity is expressly permitted by applicable law notwithstanding this limitation.

* Rental. You may not rent, lease or lend the SOFTWARE PRODUCT.

* Embedding. The SOFTWARE PRODUCT contains font software which generates typeface designs ("Font Software"). You may not separate the Font Software from the SOFTWARE PRODUCT. You may not embed the Font Software into a document which is distributed as a commercial product in exchange for a fee or other consideration (For example, you may not embed Font Software into an electronic book that is offered to the the public for a fee).

You may not embed or transmit the Font Software in any format or document which permits such Font Software to be edited or manipulated by a third party.

* Software Transfer. You may permanently transfer all of your rights under this EULA, provided you retain no copies, you transfer all of the SOFTWARE PRODUCT (including all component parts, the media and printed materials, any upgrades, this EULA, and, if applicable, the Certificate of Authenticity), and the recipient agrees to the terms of this EULA.

3. ALL RIGHTS NOT EXPRESSLY GRANTED HEREIN ARE RESERVED BY DESHWEB.

4. TERMINATION. Without prejudice to any other rights, Deshweb may terminate this EULA if you fail to comply with the terms and conditions of this EULA. In such event, you must destroy all copies of the SOFTWARE PRODUCT and all of its component parts.

5. COPYRIGHT. All title and copyrights in and to the SOFTWARE PRODUCT (including but not limited to any images, photographs, animations, video, audio, music, text, and "applets" incorporated into the SOFTWARE PRODUCT), the accompanying printed materials, and any copies of the SOFTWARE PRODUCT are owned by Deshweb or its suppliers. The SOFTWARE PRODUCT is protected by copyright laws and international treaty provisions. Therefore, you must treat the SOFTWARE PRODUCT like any other copyrighted material. You may not copy the printed materials accompanying the SOFTWARE PRODUCT.

6. EXPORT RESTRICTIONS. You acknowledge that the SOFTWARE PRODUCT licensed hereunder is subject to the export control laws and regulations of India, and any amendments thereof. You confirm that with respect to the SOFTWARE PRODUCT, you will not export or re-export it, directly or indirectly, to any countries that are subject to India's export restrictions. You further acknowledge that the SOFTWARE PRODUCT may include technical data subject to export and re-export restrictions imposed by Indian law.

MISCELLANEOUS

If you acquired this product in India, this EULA is governed by the laws of the State of Andhra Pradesh, India. Each of the parties hereto irrevocably attorns to the jurisdiction of the courts of the State of Andhra Pradesh and further agrees to commence any litigation which may arise hereunder in the courts located in the Judicial District of Hyderabad, Andhra Pradesh.

If this product was acquired outside India, then local law may apply.

If you are interested in additional information on licensing or use of Aksharamala, please visit the Aksharamala Web site at http://www.aksharamala.com/. Should you have any questions concerning this EULA, or if you desire to contact Deshweb for any reason, please contact the Authorized agent serving your country, or write: Deshweb.com Pvt. Ltd. 62, Sunder Nagar, Hyderabad, AP 500038.

LIMITED WARRANTY

NO WARRANTIES. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, DESHWEB AND ITS SUPPLIERS DISCLAIM ALL WARRANTIES AND CONDITIONS, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-INFRINGEMENT, WITH REGARD TO THE SOFTWARE PRODUCT, AND THE PROVISION OF OR FAILURE TO PROVIDE SUPPORT SERVICES. THIS LIMITED WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS. YOU MAY HAVE OTHERS, WHICH VARY FROM STATE/JURISDICTION TO STATE/JURISDICTION.

LIMITATION OF LIABILITY. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL DESHWEB OR ITS SUPPLIERS BE LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT, OR CONSEQUENTIAL DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, OR ANY OTHER PECUNIARY LOSS) ARISING OUT OF THE USE OF OR INABILITY TO USE THE SOFTWARE PRODUCT OR THE PROVISION OF OR FAILURE TO PROVIDE SUPPORT SERVICES, EVEN IF DESHWEB HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. IN ANY CASE, DESHWEB'S ENTIRE LIABILITY UNDER ANY PROVISION OF THIS EULA SHALL BE LIMITED TO THE GREATER OF THE AMOUNT ACTUALLY PAID BY YOU FOR THE SOFTWARE PRODUCT OR US$5.00; PROVIDED HOWEVER, IF YOU HAVE ENTERED INTO A DESHWEB SUPPORT SERVICES AGREEMENT, DESHWEB'S ENTIRE LIABILITY REGARDING SUPPORT SERVICES SHALL BE GOVERNED BY THE TERMS OF THAT AGREEMENT. BECAUSE SOME STATES AND JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY, THE ABOVE LIMITATION MAY NOT APPLY TO YOU.


Future Releases

Following are some features we have planned for the future releases of Aksharamala:

  • More product offerings addressing diverse needs:
    • IM Edition for the casual user interested in instant messaging in local languages
    • ActiveX control that allows the programmer to integrate Aksharamala functionality into any Windows application including IE/Web based applications.
  • Support for more Indian Languages. Our intention is to support all official Indian Languages in the near future.

Have any ideas? Add them to the Wish List!


Installing Aksharamala 2002

Installing Aksharamala

Installing Aksharamala is as easy as double clicking on the downloaded .exe file. If you have received a CD your install would start when you pop in the CD to your computer (if not find and open autorun.html).

For proper working of Aksharamala several system components need to be up-to-date. Specifically, the following Microsoft products:

  1. Uniscribe: Uniscribe is a Microsoft windows component that is responsible for rendering Unicode text. Different Windows platforms such as Windows 98, NT4, ME, 2000, XP have different versions of this component (usp10.dll) based on several factors including what products and service packs have been installed on them. Since Aksharamala is dependent on this key component (for proper rendering of Unicode text that it generates) we ship IE 6.0 setup to install or upgrade the usp10.dll.

    IMPORTANT NOTE for Windows 2000 users: Starting from Windows 2000 Microsoft has prevented updating usp10.dll (apparently as part of measures to prevent "DLL Hell") even while doing IE6 setup. In this case, a manual upgrade procedure is required to update this component. Please read this page for further information.

  2. Microsoft Installer (MSI) Runtime: Aksharamala installers use Microsoft Installer (MSI) Technology. The required run-time is already present on systems with Office 2000/XP or where other MSI based products have been previously installed. If for some reason, you prefer to install the runtime separately from Aksharamala install you could do so by downloading the runtime from the link below: (select the one corresponding to your platform)

    Windows Installer 2.0 Redistributable for Windows NT 4.0 and 2000
    Windows Installer 2.0 Redistributable for Windows 95, 98, and ME

After the install is completed please do reboot the system as recommended. This will ascertain all components are properly loaded for Aksharamala to run as designed on your system. Upon reboot, the Aksharamala icon will be loaded into the tray on your desktop in a disable state. You can right click on it and click Enable for the transliteration to work. While Aksharamala is active it will handle each keystroke as entered so you are recommended to disable Aksharamala when not in use.


Installing Indic on Windows 2000

Installing Indic Support for Windows 2000

NOTE: Enabling Indic support is required for proper operation of Aksharamala.
Please keep your Windows 2000 CD ready, or find I386 directory on your system or network.

Installing Indic Support for Windows 2000

Follow these steps to install Indic Support:

  • Start Button -> Settings -> Control Panel.

  • Click on Regional Options. As shown in the window below select Indic. Click OK.
    [ This might require you to provide the Windows 2000 CD and subsequent to the Indic support addition you might need to restart the system. ]


Upgrading Uniscribe (USP10.DLL) on Windows 2000 System

Although a newer USP10.DLL is necessary for the support of Telugu and other Indic languages the following process is neither recommended nor supported by Microsoft. At the time of Windows 2000's release Microsoft has officially supported only Devanagari (Hindi, Marathi, Sanskrit) and Tamil from the Indian languages. If you are a user of one of these languages you need not follow this procedure and Aksharamala is expected to work correctly for Hindi and Tamil.

Why is this update required?

A default version of this file is loaded into your \winnt\system32 directory. But this default version cannot handle Telugu processing. So, you have to get a more recent (advanced) version of USP10.dll from Microsoft. Unfortunately, Microsoft does not make it available on their download site. One way to get it at present is to join Microsoft VOLT User Community, and by doing so you can download a recent version of this DLL freely from the community's site. After downloading, you can use one of the following ways to install it in your \winnt\system32 directory:

• You can use Recovery Console to replace usp10.dll. If you have no recovery console installed on your computer, follow instructions in Windows 2000 help to do it, then restart computer in recovery mode and copy usp10.dll into windows system directory (\winnt\system32). Under recovery console you see very restricted set of directories, so be sure to copy new version into the same directory (under different name) before restart. Also make a backup copy of old version.

• If you don't want to replace your original USP10.dll, you can copy the new DLL directly to the directory where the application’s (such as Notepad, WordPad, IE5.5) executable resides. Most applications will pick it up from there instead of the Windows system directory. This way you enable the new Uniscribe only for selected applications and leave your system intact, and it's easier to do.


Frequently Asked Questions

What is Aksharamala?

Aksharamala is a slick, standards-based input mechanism that allows you to use an English keyboard to input text in Indian Languages. The characters you type in English are automatically transliterated to the language of your choice. It facilitates this transliteration in most Unicode-compliant software applications such as newer versions of Internet Explorer, MS Outlook, Outlook Express etc. Some Unicode non-compliant applications such as Yahoo messenger are supported using ASCII based fonts such as Shusha for Devanagari.

Aksharamala does not have a separate GUI, but it rather works as a conduit for transliteration between the keyboard and the target application.

How is this software different from other solutions such as ePatra or langoo?

This software addresses the inherent restrictions of those solutions. Specifically,

  • It is client-based, other solutions are mostly server-based, and so not generic
  • It does not require the user to be connected to the Internet
  • Other solutions are server-based and work only in the respective controls (For example, ePatra has specific edit controls for input and display of Indic language text), our solution works in any Unicode-compliant software.
  • In fact, this solution is more expansive in terms of platforms and the usage is more intuitive than even Microsoft's solutions in this domain.

What can I use it for?

The following is a list of possible uses of the software and is by no means exhaustive.

  1. Send receive emails using your *existing* email account using HTTP, POP3 etc. You can use the product to send email in Hindi, Marathi, Sanskrit and Tamil using Unicode-compliant mail programs such as Outlook Express 5.0+, Outlook 2000, Hotmail etc. The recipients can view it provided they have a Unicode-compliant font or better yet they can download Aksharamala to reply you in your language. For viewing they can download our font for free from here.
  2. Chat in your favorite Indian language using IM such as Yahoo Messenger or MSN Messenger!
  3. Send emails using Outlook Express 5.0 without the recipient needing to download any additional software!
  4. Participate in Hindi, Marathi, Sanskrit, Tamil discussions (without having to write in English!)
  5. Create HTML web pages with Indic content
  6. Create documents with Rich Text Format
Click here to check out the Application Compatibility List, which should give you an idea of what Win32 applications are compatible with Unicode and Aksharamala. We will be updating this list as we test new applications and new versions of the products listed. Let us know if you need information on any other application.

Following are some advanced uses of Aksharamala:

  1. Ability to convert "hacked"/ASCII fonts based content to Unicode. This will make the content more portable and standards-compliant.
  2. Pro Edition addresses the needs of serious users
  3. Enterprise Edition for the serious business applications developer. This is to integrate use of Indian languages in corporate service offerings.

What platforms can I use Aksharamala on?

You can use this software on Windows 98, NT, ME, 2000 and Windows XP platforms.

What languages can I use this tool with?

The current release of the product is for Hindi, Marathi, Sanskrit, Telugu and Tamil. Pretty soon, we will be releasing it for some more Indian languages.

How about fonts for the software?

All licensed Aksharamala Pro versions include commercial quality fonts for the given language.

How do I enable Aksharamala?

Press the hot key (default is Ctrl+Shift+T) or right click on Aksharamala and select Enable.

How do I disable Aksharamala?

Press the hot key (default is Ctrl+Shift+T) or right click on Aksharamala and select Disable.

What transliteration scheme do you use?

We use ITRANS as our transliteration scheme for Devanagari and Tamil; Both ITRANS and RTS are supported for Telugu.

How do I switch to another language?

Right-click on the Aksharamala tray icon select the language and input scheme from the displayed options. Alternately, you can press hotkey Ctrl+Shift+N while Aksharamala is active.

Can I use multiple languages in the same session interchangeably?

Yes, you certainly can.

How much does it cost?

Aksharamala Pro version is priced US $29.99.

I am building an application that requires input in Indian languages. Can I integrate Aksharamala into my application to support that functionality under my program's control?

You definitely can. For this you need our API component that provides you the necessary functions to enable / disable Aksharamala, select a language. This component is sold separately and is useful for application developers.


Features

Pasteliterate

Pasteliterate is a feature of Aksharamala that allows you to do on-the-fly conversion from the source format into the target language. The following is a step-by-step way to do the conversion:

  1. Select and copy the text into clipboard. (by pressing Ctrl+C or Edit/Copy)
  2. Bring into focus the application which needs to receive the converted text.
  3. Enable Aksharamala.
  4. Select the appropraite keymap (say "Shusha Reversliteration" if you are converting Shusha text to ITRANS)
  5. Press the hotkey for Pasteliterate (Ctrl+Shift+I) to achieve the conversion!

Transliteration using Multiple Keymaps

This feature allows conversion of data from one format to another using multiple keymaps. Here is how to use the feature:

  1. Right click on Aksharamala and select Options.
  2. Select "Transliteration using Multiple Keymaps" page.
  3. Select the 1st Keymap (the source data will be first processed by this keymap)
  4. Select the 2nd Keymap (resulting data from above will be fed to this keymap)
  5. Select any more keymaps as necessary.
  6. Select "Enable Multi-Keymap Translation" check box.
  7. Select and copy the text.
  8. Press the hotkey (Ctrl+Shift+M) to do the conversion!


French Keyboard Issues

Hotkeys

One of our French users running Windows 2000 (French) with American keyboard reported that the hotkeys are not mapped as expected. If you are having such issues please make sure that Aksharamala Properties windows shows the hotkeys as shown below.

Typing '^', '~' and such keys

Since pressing the AltrGr combination for ^ or ~ produces Ctrl-Alt key combinations Aksharamala transliteration logic fails to recognize them. The current workaround is to use the alternative combination for such a character. For example, to produce ऋ use RRi instead of R^i and to produce ज्ञ use GY instead of j~n. Additionally, we have added Alt-N in addition to ~N / N^ to produce ङ.


Application Compatibility List

Following is a list of applications that we have tested and found to be compatible with Aksharamala in Unicode mode. (More applications are compatible in the ASCII mode). Additional information can be obtained on each product by clicking on the application name.

Click here for a current list of Application Compatibility Issues or to post a new one.

Name of the Application |  | Windows Platform
 |  | 9x/ME |  | NT 4.0 | 2000/XP
W e b | Internet Explorer 6.0 | Yes (1. See note below for information on how to enable Indic support on Windows 2000/XP)
 | Netscape 6.2+ | No |  |  | Yes
M a i l | Outlook Express 6.0 | Yes (Please select Rich Text Format before sending emails containing Indian Language text for the recipient to successfully read it in the intended format. Click on the application for detailed instructions.)
 | Outlook 97/98/2000/XP
 | Hotmail
 | Yahoo!
 | Newsgroups / Web mail
I M | MSN Messenger 3.x/4.x | Yes
Word P r o c e s s o r s | WordPad 2 | Yes? | Yes | No | Yes
 | Word XP / Office XP | Yes
 | BharateeyaOO.o (Localized versions of OpenOffice by NCST for Windows 2000 or XP) | No |  |  | Yes
 | OpenOffice from OpenOffice.org | Yes3 |  |  | No
 | LedIt! 3.0 | No |  |  | Yes
Plain Text E d i t o r s | Notepad | No |  |  | Yes
 | BabelPad | Yes
 | UnicEdit | No |  | Yes
H T M L | FrontPage XP | Yes
 | Netscape Composer 6.2+ | No |  |  | Yes
  1. On Windows 2000 you are required to enable Indic support. Follow this link for instructions.
  2. Wordpad compatibility given above is for Hindi and Tamil; other languages (such as Telugu) has less support from WordPad.
  3. The OpenOffice version from OpenOffice.org supports Indic text in the word processor and partially in other places while running on 9x/ME. For 2000/XP use the BharateeyaOO.o version.


Microsoft Office

MS Office

Besides Outlook 97/98/2000 we do not support any of the other Office 2000 (or older) applications including Word 97/2000. This is due to inherent limitations of these older applications. Please read this link for more information on why these applications do not work with Indic/Unicode content.

Office XP

Before you can use Hindi and other Indic languages in Office XP applications (including Word XP) you would need to add the respective language support via Office XP Language settings. You can do this by following steps:

  1. Run Programs -> Microsoft Office Tools -> Microsoft Office XP Language Settings.
  2. Add Hindi to Enabled Languages.

Word XP

NOTE: Word 2000 (US English Edition) does not support Indic scripts via Unicode.

Additionally, Word XP may require the following steps for adding font substitution:

  1. First add Hindi support to Office supported languages (using instructions above).
  2. Type a Hindi word (square boxes show now).
  3. Now go to Tools -> Options -> Compatibility -> Font Substitution.
  4. If font against "Mangal" is Courier New, change it to "Devanagari MT".
  5. Select "Convert permanently" and click OK.


Hotmail

Sending mails using Hotmail

You need to select Rich Text Format in order to send Emails containing Indian Language text.

  1. Login into your account and click on Compose.
  2. Make sure Aksharamala is not active at the present time. If Aksharamala is active then disable it.
  3. Specify destination email address in the To: box (optionally in Cc: box).
  4. Specify a subject in the Subject: box.
    (Subject is recommended to be in English because many mail servers can not handle non-English subject titles)
  5. Select Rich Text Format check box (or leave it enabled)
  6. Now Enable Aksharamala.
  7. Now start typing your message. If you are not sure about the transliteration scheme refer to the one provided with Aksharamala installation. You can find it at Programs / Aksharamala.


Outlook 97/98/2000/XP

Sending mails using Outlook

  1. Start a new Mail Message by pressing on New Mail, or by selecting Message / New Message from the menu or by simply pressing Ctrl + N.
  2. Make sure Aksharamala is not active at the present time. If Aksharamala is active then disable it.
  3. Specify destination email address in the To: box (optionally in Cc: box).
  4. Specify a subject in the Subject: box. (Subject is recommended to be in English because many mail programs can not handle non-English subject titles)
  5. Make sure Rich Text format is selected or select it from menu: Format / Rich Text (HTML).
  6. Select Devanagari MT from the font selection. Increase the font size as needed.
  7. Now Enable Aksharamala.
  8. Now start typing your message. If you are not sure about the transliteration scheme refer to the one provided with Aksharamala installation. You can find it at Programs / Aksharamala.


Yahoo! Mail

Sending mails using Yahoo!

  1. Login into your account and click on Compose.
  2. Make sure Aksharamala is not active at the present time. If Aksharamala is active then disable it.
  3. Specify destination email address in the To: box (optionally in Cc: box).
  4. Specify a subject in the Subject: box. (Subject is recommended to be in English because many mail programs can not handle non-English subject titles)
  5. Click on "Switch to Formatted Version". (or do nothing if you see "Switch to Plain version")
  6. Now Enable Aksharamala.
  7. Now start typing your message. If you are not sure about the transliteration scheme refer to the one provided with Aksharamala installation. You can find it at Programs / Aksharamala.


Printing Issues

Some users reported printing problems while using older drivers for their printers. It is recommended that you upgrade your printer drivers to ensure that they have proper support for printing Unicode text.

  • HP Driver Downloads
  • Epson Printer Downloads
  • Lexmark Printer Drivers
  • Google's page on Printer Drivers
  • Guide to finding Device Drivers


Usenet Newsgroups & Web-based Email

NOTE: Although the instructions below works for most cases your web-based mail or newsreader
should support Unicode / UTF-8 in order to achieve maximum compatibility.
Click here for any updated information

The instructions below might work if you are using a web based email other than than popular hotmail or yahoo or a newsreader which doesn't explicitly support Unicode / UTF-8.

  1. Before you type any text change the Encoding of the current page to UTF-8, you can do this by Right-click -> Encoding -> More -> Unicode (UTF-8) in Internet Explorer.
  2. It is advised that you keep the subject in English. Most mail / news programs do not work very well for non-English subjects.
  3. Aksharamala Forums has a limited number of newsgroups available. Our newsgroups interface automatically transmits the content in UTF-8. Click here to view the current list of available newsgroups.


WordPad

NOTE: WordPad works well to save Indic Unicode text by using Rich Text Format
to save your documents on Windows 98, ME, 2000, XP.
The WordPad versions on Windows 95 & NT 4.0 DO NOT work!
Click here for any updated information

For maximum compatibility across 98, ME, 2000 and XP platforms save your document in Rich Text Format.

  1. Type your document as you would normally do.
  2. Enable Aksharamala and type the required Indic text.
  3. Use File -> Save As... and select Save as type to be "Rich Text Format (.rtf)"


Devanagari Key Combinations With Examples

Devanagari Input Key Combinations - ITRANS

Key Combinations | Character(s) | Sample Input | Output | Meaning in English | Phonetic Explanation
VOWELS
a | अ | avataar | अवतार | Incarnation |
aa=A | आ | aakaash | आकाश | Sky |
i | इ | imalii | इमली | Tamarind |
ii= I | ई | iishvar | ईश्वर | Lord Ishwar |
u | उ | upanyaas | उपन्यास | Book |
uu=U | ऊ | uupar | ऊपर | Above |
R^i=RRi | ऋ | R^ishi | ॠषि | Saint | aru
R^I=RRI | ॠ |  |  |  | aruu
L^i=LLi | ऌ |  |  |  | alu (archaic)
L^I=LLI | ॡ |  |  |  | aloo (archaic)
e.c | ऍ |  |  |  |
e | ए | ek | एक | One |
ai | ऐ | ainak | ऐनक | Spectacles |
aa.c | ऑ |  |  |  |
o | ओ |  |  |  |
au | औ | aurat | औरत | Woman |
CONSONANTS
k | क | kalam | कलम | Pen |
kh | ख | khabar | खबर | Donkey |
g | ग | gaNesh | गणेश | Lord Ganesh |
gh | घ | ghaDii | घडी | Clock |
~N=N^ | ङ | ma~NgaL | मङ्गळ | Auspicious | inga
ch=c | च | chakr | चक्र | Wheel |
Ch=chh=C | छ | Chatr | छत्र | Shelter |
j | ज | jag | जग | World |
jh | झ | jhalak | झलक | Sample |
~n=JN | ञ |  |  |  | iNi
T | ट | TamaaTar | टमाटर | Tomato |
Th | ठ | Thaharanaa | ठहरना | Lesson |
D | ड | Dar | डर | Box |
Dh | ढ | Dhalanaa | ढलना | Drum |
N | ण | gaN | गण | Arrow |
t | त | talaash | तलाश | Search |
th | थ | thakaan | थकान | Tiredness |
d | द | das | दस | Ten |
dh | ध | dhaDakan | धडकन | Heartbeat |
n | न | namak | नमक | Salt |
p | प | patni | पत्नि | Wife |
ph | फ | pharishtaa | फरिश्ता | Angel |
b | ब | barf | बर्फ | Ice |
bh | भ | bhakti | भ‌क्ति | Devotion |
m | म | man | म‌न | Will/Heart |
y | य | yaksh | यक्ष | Yaksha |
r | र | ratn | रत्न | Diamond |
l | ल | lataa | लता | Creeper/Branch |
v=w | व | vakt | वक्त | Time |
sh=S | श | shanivaar | शनिवार | Saturday |
Sh=shh | ष | santoSh | सन्तोष | Happiness |
s | स | samay | समय | Time |
h | ह | ham | हम | We |
L | ळ | ma~NgaL | मङ्गळ | Auspicious |
ksh=kSh | क्ष | kshamaa | क्षमा | Forgiveness |
tra | त्र | kshatriy | क्षत्रिय | Warrior |
GY=dny | ज्ञ | yajn | यज्ञ | Fire Ritual |
SYMBOLS
.N | ँ | maa.N | माँ | Mother | candrabindu
.n=M | ं | mai.n | मैं | I (myself) | anusvara
H | ः | namaH | नमः | Regards | visarga
.a | ऽ | raamaa.alay | रामाऽलय | Rama's Temple | avagraha
.h | ् | kariShyet.h | करिष्येत् | Performing (pooja) | virama == halant
OM=AUM | ॐ |  |  |  | OM
DIGITS (Available in Devanagari Strict ITRANS Schema and Digits, Symbols Schema)
0 | ० |  |  |  | ZERO
1 | १ |  |  |  | ONE
2 | २ |  |  |  | TWO
3 | ३ |  |  |  | THREE
4 | ४ |  |  |  | FOUR
5 | ५ |  |  |  | FIVE
6 | ६ |  |  |  | SIX
7 | ७ |  |  |  | SEVEN
8 | ८ |  |  |  | EIGHT
9 | ९ |  |  |  | NINE
Vedic Accents (Available in Devanagari Strict ITRANS Schema)
\` | ॑ |  |  |  | Udatta
\_ | ॒ |  |  |  | Anudatta


Devanagari Quick Summary

ITRANS - Devanagari

Devanagari version of Aksharamala supports inputting Hindi, Marathi or Sanskrit text using ITRANS input scheme. The default input schemes for Hindi and Marathi installation do not convert ASCII digits and period to the Devanagari equivalents. This is done based on the user feedback since Devanagari digits, Danda (।) and Double Danda (॥) are not used for colloquial Devanagari usage. We recommend that you use our 'Devanagari Strict ITRANS Input Scheme' for complete implementation of ITRANS 5.30 input scheme.

Key Combinations | Translated Characters
SYMBOLS
.c | ॅ
.N | ँ
M=.n | ं
H | ः
.a | ऽ
.h | ्
OM=AUM | ॐ

Key Combinations | Translated Characters | Key Combinations | Translated Characters
VOWELS
a | अ | LLI=L^I | ॡ
aa=A | आ | e.c | ऍ
i | इ | e | ए
ii=I | ई | ai | ऐ
u | उ | o | ओ
uu=U | ऊ | au | औ
RRi=R^i | ऋ | aM | अं
RRI=R^I | ॠ | aH | अः
LLi=L^i | ऌ | aa.c | ऑ

CONSONANTS
k | क | T | ट | p | प | Sh = shh | ष
kh | ख | Th | ठ | ph | फ | s | स
g | ग | D | ड | b | ब | h | ह
gh | घ | Dh | ढ | bh | भ | L | ळ
~N = N^ | ङ | N | ण | m | म | ksh = kSh | क्ष
ch | च | t | त | y | य | GY = dny | ज्ञ
chh = Ch | छ | th | थ | r | र |  |
j | ज | d | द | l | ल |  |
jh | झ | dh | ध | v = w | व |  |
~n = JN | ञ | n | न | sh = S | श |  |

SPECIALS/ACCENTS
qa | क़ | Ka | ख़ | Ga | ग़ | Ja=za | ज़
fa | फ़ | .Da | ड़ | .Dha | ढ़ | R | र्‍

DIGITS (Available in ITRANS Strict or Devanagari Digits Scheme)
1 | १ | 2 | २ | 3 | ३ | 4 | ४ | 5 | ५
6 | ६ | 7 | ७ | 8 | ८ | 9 | ९ | 0 | ०

MARATHI SPECIALTIES (Available in Marathi Transliteration Scheme)

R र्‍ kt क्‍त

SANSKRIT SPECIALTIES (Available in Strict ITRANS Scheme)
\` | ॑ | Udatta
\_ | ॒ | Anudatta

For more information on ITRANS please visit its creator Avinash Chopde's homepage here.


Telugu RTS Key Combinations With Examples

Telugu Input Key Combinations - RTS

Key Combinations | Character(s) | Sample Input | Output | Meaning in English | Phonetic Explanation
VOWELS
a | అ | amma | అమ్మ | Mommy |
aa=A | ఆ | aavu | ఆవు | Cow |
i | ఇ | illu | ఇల్లు | House |
ii=I | ఈ | iiga | ఈగ | Fly |
u | ఉ | uduta | ఉడుత | Squirrel |
uu=U | ఊ | uuyala | ఊయల | Swing |
R=r' | ఋ | Rshi | ఋషి | Saint | aru
RU=r'u | ౠ |  |  |  | aruu
~l | ఌ |  |  |  | alu
~L | ౡ |  |  |  | aloo
e | ఎ | eluka | ఎలుక | Mouse |
E | ఏ | Enugu | ఏనుగు | Elephant |
ai | ఐ | aidu paisalu | ఐదు పైసలు | Five Paisa |
o | ఒ | oMTe | ఒంటె | Camel |
O | ఓ | Oda | ఓడ | Ship |
au | ఔ | auShadhamu | ఔషధము | Medicine |
CONSONANTS
k | క | kalamu | కలము | Pen |
kh | ఖ | khaDgamu | ఖడ్గము | Sword |
g | గ | gada | గద | Mace |
gh | ఘ | ghaMTa | ఘంట | Bell |
~m | ఙ |  |  |  |
ch=c | చ | chakramu | చక్రము | Wheel |
Ch=C=c' | ఛ | Chadamu | ఛదము | Hut |
j | జ | jada | జద |  |
jh | ఝ |  |  |  |
~n | ఞ | j~nAnamu | జ్ఞానము | Knowledge | iNi
T=t' | ట | TamOTa | టమోట | Tomato |
Th=th' | ఠ | kaMThamu | కంఠము | Neck |
D=d' | డ | Damaru | డమరు | Hand Drum |
Dh=dh' | ఢ | DhaMka | ఢంక | Large Drum |
N | ణ | viiNa | వీణ |  |
t | త | tala | తల | Head |
th | థ | rathamu | రథము | Chariot |
d | ద | daMDa | దండ | Garland |
dh | ధ | dhanassu | ధనస్సు | Bow |
n | న | naga | నగ | Jewel |
p | ప | palaka | పలక | Slate |
ph | ఫ | phalamu | ఫలము | Fruit |
b | బ | baDi | బడి | School |
bh=B | భ | bhakti | భక్తి | Devotion |
m | మ | maMchamu | మంచము | Bed |
y | య | yati | యతి |  |
r | ర | ravi | రవి | Sun |
l | ల | lakshmI | లక్ష్మీ |  |
v=w | వ | vala | వల | Net |
S | శ | shanivAramu | శనివారము | Saturday |
sh | ష |  |  |  |
s | స | samayamu | సమయము | Time |
h | హ | haMsa | హంస |  |
L=l' | ళ | tALamu | తాళము | Lock |
~r=r" | ఱ |  |  |  |
SYMBOLS
@M | ఁ |  |  |  | arasunna
M | ం |  |  |  | sunna
@H = @h | ః |  |  |  | visarga
OM | ఓం |  |  |  | OM


Telugu RTS Quick Summary

RTS - Telugu

Telugu version of Aksharamala supports inputting Telugu text using ITRANS and RTS input schemes. This page gives you a quick summary of RTS input scheme. This input scheme *does not* convert ASCII digits to the Telugu equivalents.

Key Combinations | Translated Characters
SYMBOLS
@M | ఁ
M | ం
@h=@H | ః
OM | ఓం

Key Combinations | Translated Characters | Key Combinations | Translated Characters
VOWELS
a | అ | ~L | ౡ
aa = A | ఆ | e | ఎ
i | ఇ | E | ఏ
ii = I | ఈ | ai | ఐ
u | ఉ | o | ఒ
uu=U | ఊ | O | ఓ
R=r' | ఋ | au | ఔ
RU=r'u | ౠ | aM | అం
~l | ఌ | a@h | అః

CONSONANTS
k | క | T=t' | ట | p | ప | sh | ష
kh | ఖ | Th=th' | ఠ | ph | ఫ | s | స
g | గ | D=d' | డ | b | బ | h | హ
gh | ఘ | Dh=dh' | ఢ | bh | భ | L | ళ
~m | ఙ | N | ణ | m | మ | ~r=r" | ఱ
ch | చ | t | త | y | య |  |
C=Ch=c' | ఛ | th | థ | r | ర |  |
j | జ | d | ద | l | ల |  |
jh | ఝ | dh | ధ | v = w | వ |  |
~n | ఞ | n | న | S | శ |  |

For more information on RTS check out this page.


Gujarati Key Combinations With Examples

Gujarati Input Key Combinations - ITRANS

Key Combinations | Character(s) | Sample Input | Output | Meaning in English | Phonetic Explanation
VOWELS
a | અ |  |  |  |
aa=A | આ |  |  |  |
i | ઇ |  |  |  |
ii=I | ઈ |  |  |  |
u | ઉ |  |  |  |
uu=U | ઊ |  |  |  |
R^i=RRi | ઋ |  |  |  |
R^I=RRI | ૠ |  |  |  |
e.c | ઍ |  |  |  |
e | એ |  |  |  |
ai | ઐ |  |  |  |
aa.c | ઑ |  |  |  |
o | ઓ |  |  |  |
au | ઔ |  |  |  |
CONSONANTS
k | ક |  |  |  |
kh | ખ |  |  |  |
g | ગ |  |  |  |
gh | ઘ |  |  |  |
~N=N^ | ઙ |  |  |  |
ch=c | ચ |  |  |  |
Ch=chh=C | છ |  |  |  |
j | જ |  |  |  |
jh | ઝ |  |  |  |
~n=JN | ઞ |  |  |  |
T | ટ |  |  |  |
Th | ઠ |  |  |  |
D | ડ |  |  |  |
Dh | ઢ |  |  |  |
N | ણ |  |  |  |
t | ત |  |  |  |
th | થ |  |  |  |
d | દ |  |  |  |
dh | ધ |  |  |  |
n | ન |  |  |  |
p | પ |  |  |  |
ph | ફ |  |  |  |
b | બ |  |  |  |
bh | ભ |  |  |  |
m | મ |  |  |  |
y | ય |  |  |  |
r | ર |  |  |  |
l | લ |  |  |  |
v=w | વ |  |  |  |
sh=S | શ |  |  |  |
Sh=shh | ષ |  |  |  |
s | સ |  |  |  |
h | હ |  |  |  |
L | ળ |  |  |  |
ksh=kSh | ક્ષ |  |  |  |
tra | ત્ર |  |  |  |
GY=dny | જ્ઞ |  |  |  |
SYMBOLS
.N | ઁ |  |  |  | candrabindu
.n=M | ં |  |  |  | anusvara
H | ઃ |  |  |  | visarga
.a | ઽ |  |  |  | avagraha
.h | ્ |  |  |  | virama == halant
OM=AUM | ૐ |  |  |  | OM
DIGITS (Available in Devanagari Strict ITRANS Schema and Digits, Symbols Schema)
0 | ૦ |  |  |  | ZERO
1 | ૧ |  |  |  | ONE
2 | ૨ |  |  |  | TWO
3 | ૩ |  |  |  | THREE
4 | ૪ |  |  |  | FOUR
5 | ૫ |  |  |  | FIVE
6 | ૬ |  |  |  | SIX
7 | ૭ |  |  |  | SEVEN
8 | ૮ |  |  |  | EIGHT
9 | ૯ |  |  |  | NINE


Gujarati Quick Summary

ITRANS - Gujarati

Gujarati version of Aksharamala supports inputting Gujarati text using ITRANS input scheme.

Key Combinations | Translated Characters
SYMBOLS
.N | ઁ
M=.n | ં
H | ઃ
.a | ઽ
.h | ્
OM=AUM | ૐ

Key Combinations | Translated Characters | Key Combinations | Translated Characters
VOWELS
a | અ | e.c | ઍ
aa=A | આ | e | એ
i | ઇ | ai | ઐ
ii=I | ઈ | o | ઓ
u | ઉ | au | ઔ
uu=U | ઊ | aM | અં
RRi=R^i | ઋ | aH | અઃ
RRI=R^I | ૠ | aa.c | ઑ

CONSONANTS
k | ક | T | ટ | p | પ | Sh = shh | ષ
kh | ખ | Th | ઠ | ph | ફ | s | સ
g | ગ | D | ડ | b | બ | h | હ
gh | ઘ | Dh | ઢ | bh | ભ | L | ળ
~N = N^ | ઙ | N | ણ | m | મ | ksh = kSh | ક્ષ
ch | ચ | t | ત | y | ય | GY = dny | જ્ઞ
chh = Ch | છ | th | થ | r | ર |  |
j | જ | d | દ | l | લ |  |
jh | ઝ | dh | ધ | v = w | વ |  |
~n = JN | ઞ | n | ન | sh = S | શ |  |

DIGITS
1 | ૧ | 2 | ૨ | 3 | ૩ | 4 | ૪ | 5 | ૫
6 | ૬ | 7 | ૭ | 8 | ૮ | 9 | ૯ | 0 | ૦

For more information on ITRANS please visit its creator Avinash Chopde's homepage here.


Tamil Key Combinations With Examples

Tamil Input Key Combinations - ITRANS

Key Combinations | Character(s) | Sample Input | Output | Meaning in English | Phonetic Explanation
VOWELS
a | அ |  |  |  |
aa=A | ஆ |  |  |  |
i | இ |  |  |  |
ii= ee= I | ஈ |  |  |  |
u | உ |  |  |  |
uu=oo=U | ஊ |  |  |  |
e | எ |  |  |  |
E | ஏ |  |  |  |
ai | ஐ |  |  |  |
o | ஒ |  |  |  |
O | ஓ |  |  |  |
au | ஔ |  |  |  |
CONSONANTS
k / kh / g / gh | க |  |  |  |
~N=N^ | ங |  |  |  |
ch / Ch / chh | ச |  |  |  |
j / jh | ஜ |  |  |  |
~n=JN | ஞ |  |  |  |
T / Th / D/ Dh | ட |  |  |  |
N | ண |  |  |  |
t / th / d/ dh | த |  |  |  |
n | ந |  |  |  |
^n | ன |  |  |  |
p / ph / b/ bh | ப |  |  |  |
m | ம |  |  |  |
y | ய |  |  |  |
r | ர |  |  |  |
l | ல |  |  |  |
v / w | வ |  |  |  |
sh /S/ Sh/shh | ஷ |  |  |  |
s | ஸ |  |  |  |
h | ஹ |  |  |  |
L | ள |  |  |  |
ksh=kSh | க்ஷ |  |  |  |
z | ழ |  |  |  |
SYMBOLS
.n=M | ஂ |  |  |  | anusvara
H | ः |  |  |  | aytham (visarga)
.h | ் |  |  |  | virama == halant


Tamil Quick Summary

ITRANS - Tamil

Tamil version of Aksharamala supports inputting Tamil text using ITRANS input scheme. The input schemes for Tamil do not convert ASCII digits to the Tamil equivalents.

Key Combinations | Translated Characters
SYMBOLS
M=.n | ஂ
H | ஃ

Key Combinations | Translated Characters | Key Combinations | Translated Characters
VOWELS
a | அ | e | எ
aa=A | ஆ | E | ஏ
i | இ | ai | ஐ
ii= ee= I | ஈ | o | ஒ
u | உ | O | ஓ
uu=oo=U | ஊ | au | ஔ

CONSONANTS
k / kh g / gh | க | ch / chh / Ch | ச | T / Th D / Dh | ட | t / th d / dh | த
p / ph b / bh | ப | j / jh | ஜ | l | ல | L | ள
m | ம | y | ய | r | ர | R | ற
Sh = shh | ஷ | s | ஸ | sh = S | ஷ | ksh = kSh | க்ஷ
~N = N^ | ங | N | ண | ~n = JN | ஞ | n | ந
^n | ன | v = w | வ | h | ஹ | z | ழ

For more information on ITRANS please visit its creator Avinash Chopde's homepage here.


Telugu ITRANS Key Combinations With Examples

Telugu Input Key Combinations - ITRANS

Key Combinations | Character(s) | Sample Input | Output | Meaning in English | Phonetic Explanation
VOWELS
a | అ | amma | అమ్మ | Mommy |
aa=A | ఆ | aavu | ఆవు | Cow |
i | ఇ | illu | ఇల్లు | House |
ii=I | ఈ | iiga | ఈగ | Fly |
u | ఉ | uduta | ఉడుత | Squirrel |
uu=U | ఊ | uuyala | ఊయల | Swing |
R^i=RRi | ఋ | R^iShi | ఋషి | Saint | aru
R^I=RRI | ౠ |  |  |  | aruu
L^i=LLi | ఌ |  |  |  | alu (archaic)
L^I=LLI | ౡ |  |  |  | aloo (archaic)
e | ఎ | eluka | ఎలుక | Mouse |
E | ఏ | Enugu | ఏనుగు | Elephant |
ai | ఐ | aidu paisalu | ఐదు పైసలు | Five Paisa |
o | ఒ | oMTe | ఒంటె | Camel |
O | ఓ | Oda | ఓడ | Ship |
au | ఔ | auShadhamu | ఔషధము | Medicine |
CONSONANTS
k | క | kalamu | కలము | Pen |
kh | ఖ | khaDgamu | ఖడ్గము | Sword |
g | గ | gada | గద | Mace |
gh | ఘ | ghaMTa | ఘంట | Bell |
~N=N^ | ఙ |  |  |  |
ch=c | చ | chakramu | చక్రము | Wheel |
Ch=chh=C | ఛ | Chadamu | ఛదము | Hut |
j | జ | jada | జద |  |
jh | ఝ |  |  |  |
~n=JN | ఞ | j~nAnamu | జ్ఞానము | Knowledge | iNi
T | ట | TamOTa | టమోట | Tomato |
Th | ఠ | kaMThamu | కంఠము | Neck |
D | డ | Damaru | డమరు | Hand Drum |
Dh | ఢ | DhaMka | ఢంక | Large Drum |
N | ణ | viiNa | వీణ |  |
t | త | tala | తల | Head |
th | థ | rathamu | రథము | Chariot |
d | ద | daMDa | దండ | Garland |
dh | ధ | dhanassu | ధనస్సు | Bow |
n | న | naga | నగ | Jewel |
p | ప | palaka | పలక | Slate |
ph | ఫ | phalamu | ఫలము | Fruit |
b | బ | baDi | బడి | School |
bh | భ | bhakti | భక్తి | Devotion |
m | మ | maMchamu | మంచము | Bed |
y | య | yati | యతి |  |
r | ర | ravi | రవి | Sun |
l | ల | lakshmI | లక్ష్మీ |  |
v=w | వ | vala | వల | Net |
sh=S | శ | shanivAramu | శనివారము | Saturday |
Sh=shh | ష |  |  |  |
s | స | samayamu | సమయము | Time |
h | హ | haMsa | హంస |  |
L | ళ | tALamu | తాళము | Lock |
ksh=kSh | క్ష | kshatriyuDu | క్షత్రియుడు | Warrior |
GY=dny | జ్ఞ | GYAnamu | జ్ఞానము | Knowledge |
SYMBOLS
.N | ఁ |  |  |  | candrabindu
.n=M | ం |  |  |  | anusvara
H | ః |  |  |  | visarga
.h | ్ |  |  |  | virama == halant
OM=AUM | ఓం |  |  |  | OM
DIGITS (Available in Devanagari Strict ITRANS Schema and Digits, Symbols Schema)
0 | ౦ |  |  |  | ZERO
1 | ౧ |  |  |  | ONE
2 | ౨ |  |  |  | TWO
3 | ౩ |  |  |  | THREE
4 | ౪ |  |  |  | FOUR
5 | ౫ |  |  |  | FIVE
6 | ౬ |  |  |  | SIX
7 | ౭ |  |  |  | SEVEN
8 | ౮ |  |  |  | EIGHT
9 | ౯ |  |  |  | NINE


Telugu ITRANS Quick Summary

ITRANS - Telugu

Telugu version of Aksharamala supports inputting Telugu text using ITRANS and RTS input schemes. This page gives you a quick summary of ITRANS input scheme. This input scheme *does* convert ASCII digits to the Telugu equivalents.

Key Combinations | Translated Characters
SYMBOLS
.N | ఁ
M=.n | ం
H | ః
.h | ్
OM=AUM | ఓం

Key Combinations | Translated Characters | Key Combinations | Translated Characters
VOWELS
a | అ | LLI=L^I | ౡ
aa = A | ఆ | e | ఎ
i | ఇ | E | ఏ
ii = I | ఈ | ai | ఐ
u | ఉ | o | ఒ
uu=U | ఊ | O | ఓ
RRi=R^i | ఋ | au | ఔ
RRI=R^I | ౠ | aM | అం
LLi=L^i | ఌ | aH | అః

CONSONANTS
k | క | T | ట | p | ప | Sh = shh | ష
kh | ఖ | Th | ఠ | ph | ఫ | s | స
g | గ | D | డ | b | బ | h | హ
gh | ఘ | Dh | ఢ | bh | భ | L | ళ
~N = N^ | ఙ | N | ణ | m | మ | ksh = kSh | క్ష
ch | చ | t | త | y | య | GY = dny | జ్ఞ
chh = Ch | ఛ | th | థ | r | ర |  |
j | జ | d | ద | l | ల |  |
jh | ఝ | dh | ధ | v = w | వ |  |
~n = JN | ఞ | n | న | sh = S | శ |  |

DIGITS
1 | ౧ | 2 | ౨ | 3 | ౩ | 4 | ౪ | 5 | ౫
6 | ౬ | 7 | ౭ | 8 | ౮ | 9 | ౯ | 0 | ౦

For more information on ITRANS please visit its creator Avinash Chopde's homepage here.


Kannada ITRANS Quick Summary

ITRANS - Kannada

Kannada version of Aksharamala supports inputting Kannada text using ITRANS input scheme. This page gives you a quick summary of ITRANS input scheme. This input scheme *does* convert ASCII digits to the Kannada equivalents.

Key Combinations | Translated Characters
SYMBOLS
.N | ಃ
M=.n | ಂ
H | ಃ
.h | ್
OM=AUM | ಓಂ

Key Combinations | Translated Characters | Key Combinations | Translated Characters
VOWELS
a | ಅ | LLI=L^I | ೡ
aa = A | ಆ | e | ಎ
i | ಇ | E | ಏ
ii = I | ಈ | ai | ಐ
u | ಉ | o | ಒ
uu=U | ಊ | O | ಓ
RRi=R^i | ಋ | au | ಔ
RRI=R^I | ೠ | aM | ಅಂ
LLi=L^i | ಌ | aH | ಅಃ

CONSONANTS
k | ಕ | T | ಟ | p | ಪ | Sh = shh | ಷ
kh | ಖ | Th | ಠ | ph | ಫ | s | ಸ
g | ಗ | D | ಡ | b | ಬ | h | ಹ
gh | ಘ | Dh | ಢ | bh | ಭ | L | ಳ
~N = N^ | ಙ | N | ಣ | m | ಮ | ksh = kSh | ಕ್ಷ
ch | ಚ | t | ತ | y | ಯ | GY = dny | ಜ್ಞ
chh = Ch | ಛ | th | ಥ | r | ರ |  |
j | ಜ | d | ದ | l | ಲ |  |
jh | ಝ | dh | ಧ | v = w | ವ |  |
~n = JN | ಞ | n | ನ | sh = S | ಶ |  |

DIGITS
1 | ೧ | 2 | ೨ | 3 | ೩ | 4 | ೪ | 5 | ೫
6 | ೬ | 7 | ೭ | 8 | ೮ | 9 | ೯ | 0 | ೦

For more information on ITRANS please visit its creator Avinash Chopde's homepage here.


Hindi Keyboard Layout

`
ऍ
1
ॅ
2
्र
3
र्
4
ज्ञ
5
त्र
6
क्ष
7
श्र
8
(
9
)
0
ः
-
ऋ
ृ
BS
Tab
q औ
ौ
w ऐ
ै
e आ
ा
r ई
ी
t ऊ
ू
y भ
ब
u ङ
ह
i घ
ग
o ध
द
p झ
ज
[ ढ
ड
] ञ
़
\ ऑ
ॉ
Caps
a ओ
ो
s ए
े
d अ
्
f इ
ि
g उ
ु
h फ
प
j ऱ
र
k ख
क
l थ
त
; छ
च
' ठ
ट
CR
Shift z
x ँ
ं
c ण
म
v न
b व
n ळ
ल
m श
स
, ष
,
. ।
.
/ य़
य
Shift
  1. Devanagari digits can be obtained by pressing Alt+digit.
  2. Punctuation symbols (like ', ;) can be obtained by pressing Alt (or Alt+Shift) and corresponding character.
  3. ॐ (OM) can be obtained by pressing Alt+Shift+X.


Marathi Keyboard Layout

`
ऍ
१
ॅ
२
्र
३
र्
४
ज्ञ
५
त्र
६
क्ष
७
श्र
८
(
९
)
०
ः
-
ऋ
ृ
BS
Tab
q औ
ौ
w ऐ
ै
e आ
ा
r ई
ी
t ऊ
ू
y भ
ब
u ङ
ह
i घ
ग
o ध
द
p झ
ज
[ ढ
ड
] ञ
़
\ ऑ
ॉ
Caps
a ओ
ो
s ए
े
d अ
्
f इ
ि
g उ
ु
h फ
प
j ऱ
र
k ख
क
l थ
त
; छ
च
' ठ
ट
CR
Shift
z ्‍
x ँ
ं
c ण
म
v न
b व
n ळ
ल
m श
स
, ष
,
. ।
.
/ य़
य
Shift

Additionally, the following key combinations are recognized:

Description | in English | Devanagari | Result
eyelash-R | jd | र ् | र्‍
Marathi-kt | kdl | क ् त | क्‍त
Roman Digits | Alt + (0-9) |  | 0-9
Specials | Alt + [ ] ' " etc. |  | [ ] ' " etc.
OM or AUM | Alt+Shift+X | ॐ | ॐ


Sanskrit Keyboard Layout

` ऒ
ॊ
ऍ
1
ॅ
2
्र
3
र्
4
ज्ञ
5
त्र
6
क्ष
7
श्र
8
(
9
)
0
ः
-
ऋ
ृ
BS
Tab
q औ
ौ
w ऐ
ै
e आ
ा
r ई
ी
t ऊ
ू
y भ
ब
u ङ
ह
i घ
ग
o ध
द
p झ
ज
[ ढ
ड
] ञ
़
\ ऑ
ॉ
Caps
a ओ
ो
s ए
े
d अ
्
f इ
ि
g उ
ु
h फ
प
j ऱ
र
k ख
क
l थ
त
; छ
च
' ठ
ट
CR
Shift
z ऎ‍
ॆ
x ँ
ं
c ण
म
v ऩ
न
b ऴ
व
n ळ
ल
m श
स
, ष
,
. ।
.
/ य़
य
Shift

Additionally, the following key combinations are recognized:

Description | in English | Devanagari Result
Devanagari Digits | Alt + (0-9) | ० - ९
Double Danda | Alt + Period (.) | ॥
Abbreviation Sign | Alt + Comma (,) | ॰
OM or AUM | Alt + Shift + X | ॐ
Avagraha | Alt + Shift + Period (.) | ऽ
Udatta | Alt + Shift + Quote | ॑
Anudatta | Alt + Semicolon | ॒


Introduction to Keymaps

Note: For the purpose of this discussion it is assumed that user has a QWERTY keyboard and has English as the selected locale.

What is a keymap file and why it is needed?

A keymap file is a mapping file that tells the Aksharamala engine how to interpret / convert the keystrokes entered by the user. Enabling the use of a new language / keyboard layout is an incremental process using Aksharamala and does not require re-installing the software to accommodate the new keymaps. The only thing that is required is creation of a new keymap file and let Aksharamala know to use it.

Aksharamala software requires a binary keymap file to support new input scheme. To accomplish this following need to be done.

Keymap creation is a three-step process:

  1. Creation of keymap text file (.akt)
  2. Converting the above created source file to binary format (.akm)
  3. Installing the binary file (.akm) into appropriate directory

Depending upon the usage context the keymaps are classified into the following types:

  1. Transliteration Keymaps
  2. Keyboard Layout Keymaps
  3. Revers-literation Keymaps


Creating Source Keymap (.akt)

Creation of source keymap file

How to create source keymap file?

This file (with extension .akt) should be created using any text editor like notepad or any such editor that does not add any formatting characters to the original text file. Using word processing editors such as ms-word may add formatting characters to the original content. For this reason avoid using such type of editors.

What does a source keymap file contain?

Source key map file will have mapping of keys that are specific to a particular language. A source map file contains sections and keywords that are enclosed between hash sign (#), so that Aksharamala engine can interpret what need to be done, when an user types / inputs the characters. For a sample of source key map file see the excerpts shown under Transliteration Keymaps.


ASCII / Proprietary Encoding Keymaps

ASCII (proprietary fonts) keymaps are more complex than the creation of Rever-literation keymaps. Please contact us for a quote for creating these keymaps to be used with the fonts of your choice. At this time, we do not support our customers creating these keymaps on their own.

The following shows excerpts from a sample ASCII Transliteration Keymap for Vakil (Gujarati language) font:

// =======================================================
// Copyright © 2001-2003 Deshweb.com Pvt. Ltd.
// =======================================================

#id = vakil#
#virama = 0x5c, smart#
#name = Vakil for non-Unicode Usage (Beta!)#
#font = Vakil_01, 14#
#icons = 3421, 3422#
#encoding = ASCII#

#vowels#

a    'A'    0x0
aa   'Aa'   a
A
i    '['    [b]'i'        // [b] instructs 'i' to go "before consonant"
ii    0x161 'I'

/// more entries deleted for this example

#others#

.N    0xd0
M     'M'
.n
.m
H     ':'

/// more entries deleted for this example

#consonants#

k     'k'    '@'
kh    'K'    '#'
g     'ga'   'g'
gh    'Ga'   'G'

/// more entries deleted for this example

#end#


Transliteration Keymaps

These keymaps specify how to transliterate user inputted text into UNICODE (or ASCII) character values. For these transliteration keymaps, the document is divided into three sections – Vowels (includes vowels as well as vowel signs), Consonants and Others.

The entries in Vowels section specify how keystrokes get converted into UNICODE values based on the presence and position of consonant i.e. whether to use a vowel sign or vowel value. Similarly the entries in Consonants section specify whether a vowel sign is selected or not. The entries in Others section will not make a vowel sign to be selected, a matching key stroke results in a vowel.

The following shows excerpts from a sample UNICODE Transliteration Keymap for Hindi language:

// =========================================================
// Copyright © 2001-2003 Deshweb.com Pvt. Ltd.
// =========================================================

#id = hindi#
#name = Hindi Transliteration Scheme#
#virama = 0x094D, smart#
#language = Hindi#
#scheme = ITRANS#

#vowels#

// first column specifies value for vowel
//  second column is vowel sign

a     0x0905    0x0
aa    0x0906    0x093E
A

/// more entries deleted for this example

#others#

.N    0x0901        // candrabindu

M     0x0902        // anusvara
.n
.m

/// more entries deleted for this example

#consonants#

k     0x0915
kh    0x0916
g     0x0917

/// more entries deleted for this example

#end

Assuming the above keymap being used, when the user presses yaa on the keyboard Aksharamala produces:

य + ा = या

Here 'aa' ('A' would work equally same) is converted to vowel sign ा since it is followed by consonant. Where as 'aa' in aag is converted to आ as shown below:

आ + ग = आग


Reversliteration Keymaps

Revers-literation Keymaps are the keymaps that help converting content from ASCII (proprietary fonts based) to UNICODE format. The creation of this type of keymap is quite complex, labor intensive and requires thorough understanding of several issues surrounding proprietary fonts in detail.

Deshweb plans to make this process easier in the upcoming versions of developer edition. At this point of time, we do not encourage / support our customers creating these keymaps on their own and suggest them to use our services for the same.


Keyboard layout Keymaps

For Keyboard Layout Keymaps all the entries are specified in Others section. The purpose of doing this in Keyboard Layout is, each key corresponds to a fixed character value (no context information is necessary)

The following shows excerpts from a sample UNICODE Transliteration Keymap file for Hindi language:

//=======================================================
// Copyright © 2001-2003 Deshweb.com Pvt. Ltd.
//=======================================================

#id = hindikbd#
#name = Hindi Keyboard#
#language = Hindi#
#scheme = Hindi Keyboard#

#others#

!    0x090D             // Candra E
@    0x0945             // Vowel sign Candra E
\#   0x094D,0x0930      // Virama and Ra
$    0x0930,0x094D      // Ra and Virama

/// more entries deleted for this example

#end#


Compilation

Compiling a Keymap Source file

How to create binary keymap file?

Double-click on Aksharamala icon (or right-click -> Options) and select Keymap Maintenance window as shown below:

Figure A

Select "Compile Keymap" (Figure A) to select a source key map file (.akt) to convert it into a binary format (.akm). A file dialog opens up for selecting one or more (.akt) files (Figure B). After the selection process click open button. This will create a binary key map file (.akm) in the same directory.

Figure B


Installing Binary Keymap (.akm)

Installing binary keymap files

How to install binary keymap file (.akm)?

In order to install a keymap file locate the binary keymap file (.akm) created in the compile process and double click on it. This will register the new input scheme support in Aksharamala. The new feature that is added is now accessible as a menu item of the tray icon of Aksharamala.


Manually Installing / Removing Keymaps

Installing Keymaps

Aksharamala licensed users can install the binary keymaps (.akm) as well as the source keymaps (.akt) by simply double-clicking on them. Users of Aksharamala trial version can only install any keymaps in the binary form (.akm) by simply double-clicking on them.

When you are installing Keymaps from Aksharamala web site you can simply select the keymap to download from the given link and your browser will download and install the keymap into Aksharamala.

Removing Keymaps

Any keymaps that were previously added can be removed by doing the following:

  1. Go to your Aksharamala installation directory (typically C:\Program Files\Aksharamala 2003).
  2. Delete any keymaps (they end with .akm extension) that you no longer need.
  3. Execute the following command at the command line: "Akshar.exe REFRESH" (without the quotes)


How to report a Bug?

In order for us to successfully resolve a problem we need to be able to reproduce the problem in our testing environment. Besides giving details on how to reproduce the problem we would also need details of your system configuration. Here is a list of things you can send us while reporting a bug:

  1. Is the problem reproducible? If not, please try to give us as much detail as possible including how often it occurs.
  2. Details of the application you are using:
    • Name and version of the product.
    • If it is not a popular app please also tell us how to obtain the product.
    • Whether are not the application is Unicode (Indic) compliant. If you are not sure contact their product support and forward us any information you obtain. Many applications are Unicode compliant but still have problems while dealing with Indian language text.
  3. Details of your platform:
    • Windows version: 95/98/98 OSR1/98 SE/ME/NT 4.0/2000/XP
    • Service Packs Installed
    • Internet Explorer version
    • Version of USP10.DLL


Limitations of the product

Limitations

Aksharamala is designed and implemented using a generic and standards-compliant approach. Therefore, there are certain things that an application needs to do in order for Aksharamala to properly transliterate and send the input text to the target application. Please bear in mind the following to ensure Aksharamala meets your needs.

  • Unicode (Indic) support: Some of the popular applications do not support Unicode. Some do support Unicode but do not support Indic implementation of it. If the app is displaying ???? while Aksharamala is active then the most likely cause is lack of Unicode support. Some times the application should be switched to a specific mode (Rich Text / HTML etc.) before Unicode or Indian language text is successfully processed by it.
  • Typing too fast: Depending on your system performance (processor speed, hard disk response etc.) it might some times take longer for your input characters to be transliterated. Occasionally, you might notice that the English (ASCII) characters you type go un-transliterated. If you know for sure that those characters are meant to be transliterated in the given context then the cause can be that the system did not get a chance to let Aksharamala handle them and sent the characters as-is to the target application. Please try typing them slowly to resolve this problem.
  • Non-US Keyboard: If you are using Aksharamala with a non-QWERTY keyboard you might find that most of the functionality is working well. In fact, we have users who use Aksharamala with French AZERTY keyboards. With our French users there is one notable problem with the hotkeys. We would like to hear from our users with non-US keyboards if they have any concerns in using our product and would like to address them at the earliest to make using Aksharamala a satisfying experience. French Keyboard Issues.


Redirector

Please wait... Loading sitemap!


TOC

 Index
Show Site Map

  Aksharamala Help!
  Application Compatibility List
  ASCII / Proprietary Encoding Keymaps
  Compilation
  Contacting Us
  Creating Source Keymap (.akt)
  Devanagari Key Combinations With Examples
  Devanagari Quick Summary
  Features
  French Keyboard Issues
  Frequently Asked Questions
  Future Releases
  Gujarati Key Combinations With Examples
  Gujarati Quick Summary
  Hindi Keyboard Layout
  Hotmail
  How to Report a Bug
  Installing Aksharamala 2002
  Installing Aksharamala 2002
  Installing Binary Keymap (.akm)
  Installing Indic on Windows 2000
  Introduction to Keymaps
  Kannada ITRANS Quick Summary
  Keyboard Layout Keymaps
  Limitations of the product
  Manually Installing / Removing Keymaps
  Marathi Keyboard Layout
  Microsoft Office
  Outlook 97/98/2000/XP
  Printing Issues
  Redirector
  Redirector
  Revers-literation Keymaps
  Sanskrit Keyboard Layout
  System requirements
  Tamil Key Combinations With Examples
  Tamil Quick Summary
  Telugu ITRANS Key Combinations With Examples
  Telugu ITRANS Key Combinations With Examples
  Telugu ITRANS Quick Summary
  Telugu RTS Key Combinations With Examples
  Telugu RTS Quick Summary
  The License Agreement
  TOC
  Transliteration Keymaps
  Usenet Newsgroups & Web Based Email
  Welcome!
  What is Aksharamala?
  Wordpad
  Yahoo! Mail


Aksharamala Help!

This page uses frames, but your browser doesn't support them.


TOC

 TOC Site Map
Show Index

   Welcome!
   Contacting Us
   What is Aksharamala?
   System requirements
   The License Agreement
   Future Releases
   Installation
      Installing Aksharamala 2002
      Installing Indic on Windows 2000
      Upgrading Uniscribe (USP10.DLL) on Windows 2000
   Using Aksharamala
      Frequently Asked Questions
      Features
      French Keyboard Issues
   Application Compatibility
      Application Compatibility List
      Microsoft Office/Word
      Hotmail
      Outlook 97/98/2000
      Yahoo! Mail
      Printing (Driver) Issues
      Usenet Newsgroups & Web Based Email
      Wordpad
   Transliteration Schemes
      Devanagari Key Combinations
      Devanagari Quick Summary
      Telugu RTS Key Combinations With Examples
      Telugu RTS Quick Summary
      Gujarati Key Combinations With Examples
      Gujarati Quick Summary
      Tamil Key Combinations With Examples
      Tamil Quick Summary
      Telugu ITRANS Key Combinations With Examples
      Telugu ITRANS Quick Summary
      Kannada ITRANS Quick Summary
   Keyboard Schemes
      Hindi Keyboard Layout
      Marathi Keyboard Layout
      Sanskrit Keyboard Layout
   Working with Keymaps
      Introduction to Keymaps
      Creating Source Keymap (.akt)
         ASCII / Proprietary Encoding Keymaps
         Transliteration Keymaps
         Reversliteration Keymaps
         Keyboard Layout Keymaps
      Compilation
      Installing Binary Keymap (.akm)
      Manually Installing / Removing Keymaps
   Bugs & Limitations
      How to Report a Bug
      Limitations of the product


Redirector

Please wait... Loading Site Map!